GlobalShop Down

Minor incident 🚑 Life Line Emergency Vehicles Services
2025-08-18 07:09 CDT · 3 hours, 5 minutes

Updates

Resolved

GSS fixed issue after they upgraded servers this weekend.

August 18, 2025 · 10:13 CDT
Monitoring

The connectivity was restored. We are working with GSS on verifying and restoring at this time.

August 18, 2025 · 09:27 CDT
Investigating

Called GSS and asked for a callback from the Cloud team. Still waiting for more information.

August 18, 2025 · 08:45 CDT
Investigating

Still waiting for GSS to verify connectivity on their end. We do not see an internal issue at this time.

August 18, 2025 · 08:15 CDT
Issue

We have opened a ticket with GlobalShop Solutions regarding the ability to connect to their cloud instance. All GlobalShop terminal connections are unavailable.

August 18, 2025 · 07:08 CDT

← Back