Ark Internet Down

Major incident 📰 Gazette & SEIU Network 🤝 Shared Services Network
2025-07-12 10:15 CDT · 57 minutes

Updates

Resolved

Services have been restored.

July 12, 2025 · 11:13 CDT
Investigating

Internet services are restored. Currently investigating root cause and application servers.

July 12, 2025 · 10:46 CDT
Investigating

We are in touch with the datacenter and they are resetting our firewalls. We hope to be operational soon.

July 12, 2025 · 10:34 CDT
Issue

Internet services appear down at Ark. We are investigating.

July 12, 2025 · 10:15 CDT

← Back