ScreenConnect Outage

Minor incident 🐎 Cimarron Trailers Services 📰 Gazette & SEIU Services 🚑 Life Line Emergency Vehicles Services 🤝 Shared Services Services
2025-05-16 14:40 CDT · 19 hours, 56 minutes

Updates

Resolved

Screenconnect has resolved the issues with their connectivity and the system is once again fully operational.

May 17, 2025 · 10:35 CDT
Update

The vendor has acknowledged the issue is affecting multiple companies and is actively investigating the issue.

Further details can be found on the Connectwise Status Page.

May 16, 2025 · 15:30 CDT
Issue

Shared Services Technology is responding to a service-impacting event.

AFFECTED PLATFORMS:

  • Screenconnect

POTENTIAL WORKAROUNDS:

None at this time.

Because this system is externally controlled, an update will be sent when new information becomes available.

May 16, 2025 · 14:40 CDT

← Back