Zoom Outage

Major incident 🐎 Cimarron Trailers Services 📰 Gazette & SEIU Services 🚑 Life Line Emergency Vehicles 🤝 Shared Services Services
2025-04-16 14:00 CDT · 2 hours, 10 minutes

Updates

Resolved

Zoom has returned back to functional status.

April 16, 2025 · 16:09 CDT
Monitoring

https://status.zoom.us/

The Zoom Status Page is back. It would appear there is recovery underway.

April 16, 2025 · 15:30 CDT
Issue

Zoom is currently having issues. We have no ETA.

https://www.tomsguide.com/news/live/zoom-down-outage-apr-16-25

April 16, 2025 · 14:50 CDT

← Back